Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 1999-06-13 11:25:26

> (Finding a totally different way for FP is a totally different question.
> We have the language and the STL framework
> as it is now. And these functors fill some of the gaps.)
> The problem with inject_compose, distr_compose, etc. was
> that a normal programmer (who isn't familiar with FP) has no
> idea what they mean but he has to learn several names.
> With compose12 he has to learn only one easy scheme.
> May be something like
> compose1in2 for "compose 1 argument in 2 functions"
> would be better. Any opinions regarding this?
> However, I would like to avaoid a special
> name from FP that is only readable for experts.
> Make constructive criticism please and choose better names.
> I'll stay with them until we have some better
> (uless you say that compoes1in2 is better).

I've been staying out of this one, and agree with much of what has been said
before, but in practical terms I agree completely with Nico.

The meanings of "inject" and "distribute" aren't self-evident, even to
programmers like me with substantial theoretical background.

------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at