Boost logo

Boost :

From: Nicolai Josuttis (nicolai.josuttis_at_[hidden])
Date: 1999-06-13 11:19:58

Sean A Corfield wrote:
> On Friday, June 11, 1999 2:11 PM, Valentin Bonnard
> [SMTP:Bonnard.V_at_[hidden]] wrote:
> > All this mess IMHO leads to:
> > 1) almost unreadable code
> > 2) reduced use of functional programming in C++
> I agree completely Valentin.
> > And of course, it isn't on topic for this list, as
> > support for such things would require a language
> > extension. I just wanted to see if this kind of idea
> > got some support here.
> I spent three years as a postgraduate doing research into functional
> programming language design (& implementation) so I really support the FP
> idioms. Which is why I'd like to see some *readable* library code to support
> them.

Sean, Valentin, I agree, but the question is not whether they are
good names, the question is, which are better names?

(Finding a totally different way for FP is a totally different question.
 We have the language and the STL framework
 as it is now. And these functors fill some of the gaps.)

The problem with inject_compose, distr_compose, etc. was
that a normal programmer (who isn't familiar with FP) has no
idea what they mean but he has to learn several names.
With compose12 he has to learn only one easy scheme.

May be something like
compose1in2 for "compose 1 argument in 2 functions"
would be better. Any opinions regarding this?

However, I would like to avaoid a special
name from FP that is only readable for experts.
Make constructive criticism please and choose better names.
I'll stay with them until we have some better
(uless you say that compoes1in2 is better).


Nicolai M. Josuttis
Solutions in Time
------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at