Boost logo

Boost :

From: Valentin Bonnard (Bonnard.V_at_[hidden])
Date: 1999-06-15 08:36:19

Paul Baxter wrote:

> I like the idea of Jerry's names.
> However as a non-functional programmer I have problems with the
> 'compose' section. It really doesn't convey the purpose without adding
> more computer science jargon (that is easily forgotten)

Composition is basic mathematical notion, it isn't a special
c.s. term (and it isn't in the jargon file).

> How about
> composite_f_gx
> etc
> or
> combine_f_gx
> These give an indication of the nature of the functions

Does it ? Why not simply keep conpose ?

``combinator'' is a term used in functionnal programing
but I have never heard it used for math.

''composite'' is strange and says nothing to me.

Valentin Bonnard
------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at