Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 1999-07-07 21:32:46

Valentin expounded:

>> It's a good concept. I agree with Nico that the node_based part is
>> distasteful. Why not just call the algorithm erase_and_return_count or
>> something? It could give different efficiency guarantees for non-node-based
>> containers That would be analogous to the other STL components which have
>> different performance depending on iterator category.
> There is no way to write this stuff w/o traits,
> w/o user selection of the right function and
> w/o loss of genericity.

And then he said:

>No way.

Valentin, I never made a claim to the contrary. I was only talking about the
names chosen (e.g. "node_based..."), not the traits technique.


------------------------------------------------------------------------ home: - Simplifying group communications

Boost list run by bdawes at, gregod at, cpdaniel at, john at