Boost logo

Boost :

From: Nicolai Josuttis (nicolai.josuttis_at_[hidden])
Date: 2000-01-09 13:46:46

Beman Dawes wrote:
> At 01:58 PM 1/9/00 +0100, Nicolai Josuttis wrote:
> >>>>
> attached is a new version of array.hpp.
> See array.html for a description of the features.
> <<<<
> Where does that leave array_traits<> in boost's current array.hpp
> from Dietmar? (
As I wrote in my first message about this stuff.
This has nothing to do with Dietmars array stuff.
Seems we have a name clash!!!
Several ways to solve it:
 - rename class array and header
 - rename only header of class array
 - rename Dietmars header
 - use different namespaces
 - use different subdirectories

I'd prefer to rename Dietmars stuff for three reasons:
- class array seemed to be a name that fits well
  and the name of the header follows from it
- Dietmars class seems more to handle array_traits.
  So arraytraits.hpp might be a better name anyway.
- I don't have to change anything :-)

Nicolai M. Josuttis 
Solutions in Time        	mailto:solutions_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at