Boost logo

Boost :

From: Dietmar Kuehl (dietmar.kuehl_at_[hidden])
Date: 2000-01-09 19:34:01

At 04:02 PM 1/9/00 -0500, you wrote:
>At 07:46 PM 1/9/00 +0100, Nicolai Josuttis wrote:
>>I'd prefer to rename Dietmars stuff for three reasons:
>>- class array seemed to be a name that fits well
>> and the name of the header follows from it
>>- Dietmars class seems more to handle array_traits.
>> So arraytraits.hpp might be a better name anyway.
>>- I don't have to change anything :-)

It is fine with me. This issue brings up the general topic of naming
both for header files and classes to avoid conflicts with future
packages in general. However, I don't know whether it is important
enough to deal with...

>Besides resolving name clashes, we need an overview page which
>explains when to use array_traits<> vs array<> vs vector<> so users
>don't get totally confused.

Would that be worth an article in C++ Report's Boost column? Maybe
Nico and I could to a joint article on this one. However, this does not
solve the problem of having the stuff covered in the documentaton...
I have seen C++ Report articles online. Would it be permitted to
provide the printed articles online at the Boost site, eg. from a page
which links to the C++ Report?


Boost list run by bdawes at, gregod at, cpdaniel at, john at