Boost logo

Boost :

From: jsiek_at_[hidden]
Date: 2000-01-15 17:49:24

Andy Glew writes:
> (1) IHateMixedCase and prefer_underscore_separation.
> Sorry, religious topic, although shared_ptr>T> and auto_ptr<T>
> have established IMHO the right precedent. ;-}

I prefer underscore separation as well. But the mixed case is the
standard for names of *concepts*, whereas underscore separation is the
standard for function and class names. I think this differentiation
is a good thing, otherwise people could get confused about what
is what.

> (3) Why not "buffer"?
> Moreover, some of the earliest data structure references I have
> seen say "pushdown buffer" or "stack buffer" for what we now
> call a stack, and "FIFO buffer" or "queue buffer" for what we now
> call a plain old queue.

I didn't realize that the word "buffer" had been used like that...

Here's the definition of "buffer" from the Free On-line Dictionary of

There are many different algorithms for using buffers, e.g. first in
first out (FIFO or shelf), last in first out (LIFO or stack), double
buffering (allowing one buffer to be read while the other is being
written), cyclic buffer (reading or writing past the end wraps around
to the beginning).

Seeing as this is a pretty close fit to the concept, I agree with you
that "Buffer" is the right name.



Boost list run by bdawes at, gregod at, cpdaniel at, john at