Boost logo

Boost :

From: Darin Adler (darin_at_[hidden])
Date: 2000-02-15 14:47:45

I like the idea and the code. Besides things already mentioned by Ed Brey, I
have one tiny quibble:

> : inherited( variable, variable ) { variable = new_value; }

The above line can just be replaced by this.

        : auto_restore( variable, variable ) { variable = new_value; }

Unless the "inherited" typedef is a workaround for a compiler bug, it
doesn't improve things in this example. I, for one, think the version
without it is slightly easier to read.

    -- Darin

Boost list run by bdawes at, gregod at, cpdaniel at, john at