Boost logo

Boost :

From: David Abrahams (abrahams_at_[hidden])
Date: 2000-06-25 14:30:58

I agree that claiming the name "array" might be controversial, but also
wonder if we might not have the same complaint about *any* use of that name.
If someone wrote a replacement for valarray called "array", wouldn't this
line of reasoning still apply?
Just to complicate things further, I vote for array_container or some such.
You are not restricted to wrapping arrays which can be declared from 'C',
are you?


----- Original Message -----
From: "Beman Dawes" <beman_at_[hidden]>
To: <boost_at_[hidden]>; <boost_at_[hidden]>
Sent: Sunday, June 25, 2000 2:46 PM
Subject: Re: [boost] array formal review

> I would like to second Tomasz Kowalczyk's comment:
> >I have a comment about the naming of this class. I am afraid that
> >"array" has potential to be used for other things than just a wrapper
> >around C arrays. Why not to call it a "carray" so that everybody knows
> >what it refers to, and so that long threads in clc++m about stealing
> >names and introducing confusion can be avoided ?
> "array" is just too generic a name. I prefer "c_array" to "carray", but
> the important thing is to pick a name that at least hints at what kind of
> array we are talking about.
> --Beman
> ------------------------------------------------------------------------
> IT Professionals: Match your unique skills with the best IT projects at
> ------------------------------------------------------------------------

Boost list run by bdawes at, gregod at, cpdaniel at, john at