From: Kevlin Henney (kevlin_at_[hidden])
Date: 2000-07-17 13:41:34
In message <01a401bfedcf$ed449050$37781990_at_[hidden]>, Greg Colvin
>From: Beman Dawes <beman_at_[hidden]>
>> By the way, I agree the names just have to be changed or there will be
>> constant fear of macro clashes. ct_ seems cryptic; how about meta_ as in
>> meta_if ? But I'd get used to ct_if I suppose.
>Of course the simple IF form gives more readable code.
But is also a macro-style name :-(
I've got to admit that I'm partial to Beman's suggestion of meta_* for
the constructs, as this hints more than a little strongly at "template
Kevlin Henney phone: +44 117 942 2990
Curbralan Ltd mobile: +44 7801 073 508
kevlin_at_[hidden] fax: +44 870 052 2289
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk