Boost logo

Boost :

From: jsiek_at_[hidden]
Date: 2000-07-17 19:40:14

meta_if sounds good to me too.

Kevlin Henney writes:
> In message <01a401bfedcf$ed449050$37781990_at_[hidden]>, Greg Colvin
> <greg_at_[hidden]> writes
> >From: Beman Dawes <beman_at_[hidden]>
> >>
> >> By the way, I agree the names just have to be changed or there will be
> >> constant fear of macro clashes. ct_ seems cryptic; how about meta_ as in
> >> meta_if ? But I'd get used to ct_if I suppose.
> >
> >Of course the simple IF form gives more readable code.
> But is also a macro-style name :-(
> I've got to admit that I'm partial to Beman's suggestion of meta_* for
> the constructs, as this hints more than a little strongly at "template
> metaprogramming".

Boost list run by bdawes at, gregod at, cpdaniel at, john at