Boost logo

Boost :

From: Jeremy Siek (jsiek_at_[hidden])
Date: 2000-12-29 21:16:48


On Fri, 29 Dec 2000, David Abrahams wrote:
abraha> I think you are probably right. Also, given recent
abraha> discussions on splitting up operators.hpp, maybe we should
abraha> have a boost iterators library where all of this stuff can
abraha> cohabitate. It doesn't seem logical to me that people
abraha> wanting to implement iterators should have to look through
abraha> operators, iterator_adaptors, random, and perhaps
abraha> boost/iterator.hpp and boost/detail/iterator.hpp to do so.

Agreed.

abraha> While we're in the general subject area, what is your
abraha> opinion of Daryle's addition of the iterator archetypes to
abraha> operators.hpp? It's hard for me to imagine a use for these
abraha> separate from the iterator helpers, but before rejecting
abraha> the idea I thought I should ask for feedback about it.

Right. As you have pointed out, the inheritance from std::iterator is
important for reasons other than the typedefs and should be encouraged.
So I don't see a good reason to have the archetype classes. We may want to
add an input_iterator_helper... I just wasn't motivated to provide one
before.

Nit: throughout the docs, "pointer_type" should "pointer",
"reference_type" should be "reference"

Old naming issue: the standard LessThanComparable requirement only
requires operator<. Therefore the less_than_comparable operator helper
does not help one create a model of LessThanComparable. Instead it creates
the SGI STL version of LessThanComparable, which in the concept checking
library I refer to as the Comparable concept.

Cheers,
Jeremy

----------------------------------------------------------------------
 Jeremy Siek www: http://www.lsc.nd.edu/~jsiek/
 Ph.D. Candidate email: jsiek_at_[hidden]
 Univ. of Notre Dame work phone: (219) 631-3906
----------------------------------------------------------------------


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk