From: Aleksey Gurtovoy (alexy_at_[hidden])
Date: 2000-12-30 07:00:36
Jeremy Siek wrote:
> Old naming issue: the standard LessThanComparable requirement only
> requires operator<. Therefore the less_than_comparable operator helper
> does not help one create a model of LessThanComparable. Instead it creates
> the SGI STL version of LessThanComparable, which in the concept checking
> library I refer to as the Comparable concept.
The same about 'equality_comparable' class template. As I wrote a little while
ago (http://www.egroups.com/message/boost/7697), these two templates are the
only ones which do not match the proposed summary of template names semantics
(which we haven't discussed yet). IMO, we should rename them (for me
'comparable' still seems as a good replacement for 'less_than_comparable'; no
good ideas about another one, though), and add the summary notes to docs.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk