Boost logo

Boost :

From: Daryle Walker (darylew_at_[hidden])
Date: 2001-04-25 23:30:03

on 4/24/01 8:08 PM, David Abrahams at abrahams_at_[hidden] wrote:

> I still think idempotent is the wrong name. It describes a property of the
> operation it defines, rather than the concept (little 'c') completed by the
> operator template.
> "unary_plusable" is ugly but accurate and consistent with the documented
> naming strategy.

The unary + returns the value of its argument. It could be considered an
identity. So I gave it the new name "identifiable" in the newest version
(24). I think it's closer to the 'concept' of the operator. (It's tighter;
the identity function is always idempotent, but other functions can be
idempotent too.)

Daryle Walker
Mac, Internet, and Video Game Junkie
darylew AT mac DOT com

Boost list run by bdawes at, gregod at, cpdaniel at, john at