Date: 2001-07-18 11:20:15
--- In boost_at_y..., "Alexander Terekhov" <terekhov_at_d...> wrote:
> > A "lock" is a "locker" or "guard". They are all different names
> > the same concept. Or is your objection to the name chosen?
> yes, my objection is to the chosen name 'lock'. it should be
> 'locker' or 'guard'. 'lock' is a shared "device". 'locker'
> or 'guard' is a proper name for the type used to perform
> lock acquire/release _actions_ -- implement RAII idiom
> with respect to _lock_ (mtxLock, semLock, rwlLock, xxxLock)
> acquisition; also known as ScopedLocking.
The name "locker" is just awful. Guard is tolerable, but doesn't
convey the action well. I really don't understand why you find the
name "lock" to be bad. What do you mean when you say "'lock' is a
shared 'device'"? We've been settled on the name "lock" for over a
year now, with little or no complaint (others have suggested "guard",
but have given no reason for the preference and dropped the subject
with out a fight), so I need compelling arguments to consider
changing it now. This is especially true since the naming of things
rarely has a "right" answer and any time the subject is brought up
discussion degenerates into a religous flame war.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk