Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2001-07-18 12:09:10

At 10:50 AM 7/18/2001, Alexander Terekhov wrote:
>> A "lock" is a "locker" or "guard". They are all different names for
>> the same concept. Or is your objection to the name chosen?
>yes, my objection is to the chosen name 'lock'.

Is your object to "lock" when used in a class name, or as a variable name
where a lock is part of the mechanism guarding some code?


Boost list run by bdawes at, gregod at, cpdaniel at, john at