Boost logo

Boost :

From: Alexander Terekhov (terekhov_at_[hidden])
Date: 2001-07-18 09:50:36

> A "lock" is a "locker" or "guard". They are all different names for
> the same concept. Or is your objection to the name chosen?

yes, my objection is to the chosen name 'lock'. it should be
'locker' or 'guard'. 'lock' is a shared "device". 'locker'
or 'guard' is a proper name for the type used to perform
lock acquire/release _actions_ -- implement RAII idiom
with respect to _lock_ (mtxLock, semLock, rwlLock, xxxLock)
acquisition; also known as ScopedLocking.


Boost list run by bdawes at, gregod at, cpdaniel at, john at