From: Alexander Terekhov (terekhov_at_[hidden])
Date: 2001-07-18 12:21:29
> The name "locker" is just awful. Guard is tolerable,
> but doesn't convey the action well.
how about LockKeeper; similar to DirKeeper from
> I really don't understand why you find the
> name "lock" to be bad.
boost::spinlock::lock lock( lock_ );
is just awful, IMHO.
> What do you mean when you say "'lock' is a shared 'device'"?
my online english dictionary says: "lock n. 1. A device
operated..." in order to be useful it need to be shared ;)
you do not need locks if no one else has access.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk