Boost logo

Boost :

From: Kevlin Henney (kevlin_at_[hidden])
Date: 2001-07-20 10:58:03

> From: williamkempf_at_[hidden]
>problem here, though, is that the nebulous complaint you have against
>the shorter name "lock" is going to exist with "scoped_lock" as
>well. There's a conceptual difference between this sort of "lock"
>and a "spinlock".

Have you considered using the name 'locker'? This is the one I tend to
use: a locker (the scoped locking object) locks (calls the member
function) a lock (the mutex).

>A mutex is not a lock, though. It can be LOCKED, but that's not the
>same thing. If you want to look at this from an English language
>view point, the name "lock" doesn't really fit either concept

This would be a fine line of logic if it were correct... but
unfortunately it isn't :-(


  Kevlin Henney phone: +44 117 942 2990
  mailto:kevlin_at_[hidden] mobile: +44 7801 073 508 fax: +44 870 052 2289
  Curbralan: Consultancy + Training + Development + Review

Boost list run by bdawes at, gregod at, cpdaniel at, john at