Boost logo

Boost :

From: Jeremy Siek (jsiek_at_[hidden])
Date: 2001-07-20 11:38:21

"locker" also seems like a better name to me... it avoids confusion, and
since the primary purpose of these names is to communicate, avoiding
confusion is important. (and the "Lock" concept could be changed to

P.S. I was OK with "lock" before because I was reading it as a verb, which
I admit is a bit odd since it is a type, and therefore typically read as a

On Fri, 20 Jul 2001, Kevlin Henney wrote:
> > From: williamkempf_at_[hidden]
> [...]
> >My
> >problem here, though, is that the nebulous complaint you have against
> >the shorter name "lock" is going to exist with "scoped_lock" as
> >well. There's a conceptual difference between this sort of "lock"
> >and a "spinlock".
> Have you considered using the name 'locker'? This is the one I tend to
> use: a locker (the scoped locking object) locks (calls the member
> function) a lock (the mutex).
> >A mutex is not a lock, though. It can be LOCKED, but that's not the
> >same thing. If you want to look at this from an English language
> >view point, the name "lock" doesn't really fit either concept
> >perfectly.
> This would be a fine line of logic if it were correct... but
> unfortunately it isn't :-(
> Kevlin
> ____________________________________________________________
> Kevlin Henney phone: +44 117 942 2990
> mailto:kevlin_at_[hidden] mobile: +44 7801 073 508
> fax: +44 870 052 2289
> Curbralan: Consultancy + Training + Development + Review
> ____________________________________________________________
> Info: Unsubscribe: <mailto:boost-unsubscribe_at_[hidden]>
> Your use of Yahoo! Groups is subject to

 Jeremy Siek www:
 Ph.D. Candidate, IU B'ton email: jsiek_at_[hidden]
 Summer Manager, AT&T Research phone: (973) 360-8185

Boost list run by bdawes at, gregod at, cpdaniel at, john at