Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2001-11-07 18:16:32

the correct command-line for using FTJam is:

  jam -ftools/build/allyourbase.jam -sTOOLS=gcc

If you are using the jam in boost/tools/build/jam_src, you can use:

  jam -sBOOST_ROOT=. -sTOOLS=gcc

  David Abrahams, C++ library designer for hire

        C++ Booster (
          email: david.abrahams_at_[hidden]

----- Original Message -----
From: "Jesse Jones" <jesjones_at_[hidden]>
To: <boost_at_[hidden]>
Sent: Wednesday, November 07, 2001 5:12 PM
Subject: [boost] Building on OS X

> I'm having some problems building boost 1.25.1 with gcc on Mac OS
> 10.1. I first tried Jam 2.3.5 from the The FreeType Project
> SourceForge site with the following command line:
> jam -sBOOST_ROOT=tools/build/allyourbase.jam -sTOOLS="gcc"
> I got these warnings:
> warning: unknown rule project-root
> warning: unknown rule subinclude
> warning: unknown rule subinclude
> warning: unknown rule subinclude
> warning: unknown rule subinclude
> ...found 7 targets...
> and the build quit. Then I noticed the tools/build/jam_src folder so
> I went ahead and built that version of jam by typing "jam" in that
> folder. I copied the new tool into /usr/bin and tried to build boost
> again and got some new errors:
> boost-build.jam: No such file or directory
> don't know how to make all
> ...found 1 target...
> ...can't find 1 target...
> Anyone know what's going on here? Do I have to set some environment
> variables? BTW both versions of jam print the following when I use
> the -v option:
> Jam/MR Version 2.3.2. Copyright 1993, 2000 Christopher Seiwald.
> -- Jesse
> Info: Unsubscribe:
> Your use of Yahoo! Groups is subject to

Boost list run by bdawes at, gregod at, cpdaniel at, john at