Boost logo

Boost :

From: Gregory Coulon (coulon_at_[hidden])
Date: 2001-11-09 15:36:14

I ran into the same problem as Christof, and when I try to rebuild
jam from the command line, it seems unable to parse the path to VC++
that I gave it, no matter if I set it at the command line or as a
global environment variable. I tried every combination of double
quoting and escape characters that I could think of, but maybe I'm
missing something. Help!

-Gregory Coulon.

--- In boost_at_y..., "David Abrahams" <david.abrahams_at_r...> wrote:
> Rats! I went to significant trouble to try to keep requirements on
Boost Jam features out of this release, but I guess I messed it up :(.
> The documentation is not quite up-to-date, but updated instructions
for building Boost Jam have been checked in and can be viewed at:
> Here are the relevant bits:
> ------------
> a.. Download FTJam and install the binary executable where it will
be found when invoked from the command line.
> a.. For easy-to-build source files, see the FTJam site on
> b.. For Linux and Win32 pre-built executables, see the ftjam
section of the FreeType file list.
> c.. If there is no pre-built FTJam executable for your platform,
don't bother downloading the source. Instead, read the Jam build
instructions and apply them directly to the Boost Jam sources in the
tools/build/jam_src subdirectory.
> b.. If you acquired FTJam in the previous step, go to the
tools/build/jam_src subdirectory and invoke
> c.. which will build a new copy of Jam with the Boost extensions
enabled. If FTJam complains about a missing toolset variable, follow
its directions by adding the appropriate settings, e.g.:
> d.. Replace the FTJam executable with the one in the newly-created
bin.platform subdirectory.
> ----- Original Message -----
> From: <cmeerw_at_w...>
> To: <boost_at_y...>
> Sent: Thursday, November 08, 2001 9:25 AM
> Subject: [boost] Building Boost 1.25.1 (Windows NT/msvc)
> > I had some difficulties building Boost 1.25.1 with msvc on
Windows NT.
> > If I try to use the ftjam-2.3.5 binaries and try "jam
> > -ftools/build/allyourbase.jam -sTOOLS=msvc" I get a syntax error:
> > "tools/build/allyourbase.jam: line 1608: syntax error at keyword
> >
> > Using jam from the boost package seems to work with "jam
> > -sBOOST_ROOT=. -sTOOLS=msvc", but not if I try to build it
with "jam
> > -ftools/build/allyourbase.jam -sTOOLS=msvc". Then I get:
> > "new-split.jam: No such file or directory [...]"
> > Hmm, it's just a bit confusing... :-(
> >
> > bye, Christof
> >
> >
> > Info: Unsubscribe: <mailto:boost-
> >
> > Your use of Yahoo! Groups is subject to
> >
> >

Boost list run by bdawes at, gregod at, cpdaniel at, john at