Boost logo

Boost :

From: Andrei Alexandrescu (andrewalex_at_[hidden])
Date: 2001-11-26 01:05:50

> > Yes, but is_public_base suffers of the "who's first and who's second"
> > problem. Per public demand, I changed super_subclass to base_derived. So
> > base_derived<T, U>::value is true is T is the base and U is the derived.
> Minor nit: How 'bout is_base_derived<T, U>::value ?
> Would be more consistent with the existing type_traits lib (is_integral,
> is_enum, is_fundamental, is_POD, etc.).

Duly noted. So I changed the name to is_base_derived.


Boost list run by bdawes at, gregod at, cpdaniel at, john at