Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2001-11-26 16:36:16


Too bad we can't overload compile-time functions; then we could have
identity<10>::value == 10 and identity<char>::type == type.

Maybe value_identity is best... leading to type_identity for symmetry :-/

-Dave
----- Original Message -----
From: "joel de guzman" <djowel_at_[hidden]>

>
> ----- Original Message -----
> From: "Andrei Alexandrescu" :
>
> > From: "David Abrahams" <david.abrahams_at_[hidden]>
> > > BTW, isn't "identity" a much better name than "type2type"?
> >
> > Identity sounds great, I'll make that change unless there is a lot of
> > opposition.
> >
>
> identity is cool!
>
> int2type and type2type are quite, umm, unclear.
>
> How about static_int<N> instead of int2type<N> ? Syntactically, It's like
> static_cast that transforms an int to a distinct static-integer type.
>
> Or maybe, how about: int_identity<N> ?
>
> 2c worth :-)
> --Joel
>
>
>
>
>
> Info: http://www.boost.org Unsubscribe:
<mailto:boost-unsubscribe_at_[hidden]>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
>
>


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk