Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2001-12-12 09:07:20


----- Original Message -----
From: "mcseemagg" <mcseemagg_at_[hidden]>

> Since I received some positive replies I would like to investigate
> more about boost community opinions. I'd like to be responsible
> submitting the library and if I'm permitted to do that I will
> completely "boostify" the library and use appropriate licensing. But
> still there's a few questions.
>
> 1. Although boost is a great place, I wouldn't like to restrict my
> library to only boost. So, can I put some other URLs into source
> files?

There's no restriction on the inclusion of URLs in source files.

> 2. As I use some #defines I'll need to rename them to BOOST_...
> according to the hpp policy. Can I use alternative names (not
> polluting the global namespace) - like AGG_...?

I think if you really need AGG_ in your names, they should be BOOST_AGG_....

> 3. I used namespace "agg". Is it normal practice to have nested
> namespaces on boost, like boost::agg::line(...)?

Yes. A policy we're trying out is that things of general utility should live
in boost, but anything domain-specific gets its own subnamespace. Your
graphics library sounds like the latter.

<snipped 4 - no comment>

> 5. Is there any possibility to make AGG independent on boost - I mean
> name conversion (#define AGG_... instead of BOOST_..., use
> namespace "agg" instead of "boost::agg", and so on). I do not insist
> on that, it just would be preferable for me in some ways.

I think that would be a tough sell. Remember that users can always create
namespace aliases:

namespace agg = boost::agg;

They do that all the time with boost::python.

-Dave


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk