Boost logo

Boost :

From: Aleksey Gurtovoy (agurtovoy_at_[hidden])
Date: 2002-06-20 13:35:39

David Abrahams wrote:
> From: "Ralf W. Grosse-Kunstleve" <rwgk_at_[hidden]>
> > Here is what somehow evolved out of necessity in my
> > environment (to give this some street cred: I define myself
> > as a scientific programmer):
> >
> > template <class T> struct type_holder { typedef T type; };
> I believe Andrei suggested type2type<> and it met with
> general approval.

I believe a class template that "returns" the type of its argument should be
called 'identity' :). If it doesn't "return" anything and is just a "type
envelope" (the purpose of current 'boost::type<>'), then IMO it's a separate

Answering Dave's original question, I am all in favor of renaming
'boost::type<>' to something more specific according to its purpose, e.g.
'type_wrapper' or 'type2type', whatever is the general preference.


Boost list run by bdawes at, gregod at, cpdaniel at, john at