From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-06-20 14:14:37
From: "Aleksey Gurtovoy" <agurtovoy_at_[hidden]>
> I believe a class template that "returns" the type of its argument should
> called 'identity' :). If it doesn't "return" anything and is just a "type
> envelope" (the purpose of current 'boost::type<>'), then IMO it's a
Actually, identity<> is also a fine name for a type envelope: it's used to
transmit the identity of a type, its parameter... and I'd rather have just
one template than two.
However, I know there was what seemed like rancorous objection when I
suggested identity<> before; nobody seemed to get the whole metafunction
idea, so for the record, I don't care all that much what we call it.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk