From: Matthew Wilson (mwilson_at_[hidden])
Date: 2002-06-23 20:38:58
That's the best one so far.
"Joel de Guzman" <djowel_at_[hidden]> wrote in message
> Fernando Cacciola wrote:
> >>Actually, identity<> is also a fine name for a type envelope: it's
> used to
> >>transmit the identity of a type, its parameter... and I'd rather have
> >>one template than two.
> >>However, I know there was what seemed like rancorous objection when I
> >>suggested identity<> before; nobody seemed to get the whole
> >>idea, so for the record, I don't care all that much what we call it.
> >FWIW, I think that identity<> is a good name, and I agree with David
> >just providing the metafunction is enough... if you don't 'call it'
> >::type); it's just a type envelope.
> >Since you *need* to change it, I think it would be reasonable if you
> just do
> >it if nobody complains in the next few days.
> identity is a nice name. However, the name itself does not imply
> that it is a metafunction. I know it would be longish but I feel
> that type_identity would be better (it's just 1 char longer than
> Unsubscribe & other changes:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk