Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-06-26 08:49:46

----- Original Message -----
From: "Aleksey Gurtovoy" <agurtovoy_at_[hidden]>

> > I guess the right thing to do is to document 'get_pointer(px)' as
> > the raw pointer contained in px on the smart pointer side, and make
> > mem_fn_get_pointer forward to it on the mem_fn side. Comments?
> If 'get_pointer' is going to become a free-standing equivalent of 'get'
> member function, I would suggest to call it 'c_ptr' (never liked 'get'
> e.g.

What is "c_" supposed to mean? Can we see what the unabbreviated version
looks like?


Boost list run by bdawes at, gregod at, cpdaniel at, john at