Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2002-07-26 09:59:26

From: "Jeremy Siek" <jsiek_at_[hidden]>

> Hi Gennadiy, Dave,
> I'm about to start work on a new version of the iterator adaptor that
> works with the new iterator concepts that I've defined. Just a minute ago
> I had an idea for a name: iterator_builder.

As a replacement for the existing iterator_adaptor? Do you really want to
drop "adaptor" from the name? It's not a "Policy builder" pattern, after


Boost list run by bdawes at, gregod at, cpdaniel at, john at