Boost logo

Boost :

From: Gennadiy Rozental (gennadiy_at_[hidden])
Date: 2002-08-20 09:01:34

"Beman Dawes" <bdawes_at_[hidden]> wrote in message
> At 04:41 AM 8/20/2002, Gennadiy Rozental wrote:
> >> Well, that isn't quite right. "inline" isn't 100% right either, but
> >is
> >> seems better than "online" to me.
> >I think that inline would be misleading (at least for the Test/Program
> >Execution Monitor headers ) since in fact library is implemented
> >Maybe we could separate it into
> >
> >boost/test/online/test_execution_monitor.hpp
> >boost/test/online/prg_execution_monitor.hpp
> >and
> >boost/test/minimal.hpp or boost/test/lightweight.hpp ?
> I think changing the directory name to "basic", "lite", "lightweight", or
> similar would be better:
> boost/test/basic/...

But there is nothing basic or lite in test_execution_monitor.hpp and
prg_execution_monitor.hpp. It's simply inlined through direct source
inclusion of all sources.


Boost list run by bdawes at, gregod at, cpdaniel at, john at