Boost logo

Boost :

From: Victor A. Wagner, Jr. (vawjr_at_[hidden])
Date: 2002-08-24 14:44:05

I didn't come up with the name. I wouldn't have suggested it myself, but
I recall it being a popular name back when Pascal was in common use. I was
reminded of the name when I was pointed to a white paper by per Brinch
Hansen on condition variables in which he mentioned the name.

I believe it came from: if you have a universe of n enumerated items, then
you can represent _any_ set of them in something with 2^n states.

Pascal implemented such a concept and called it 'set'

At Saturday 2002/08/24 11:03, you wrote:

>From: "Victor A. Wagner, Jr." <vawjr_at_[hidden]>
> >I hope I suggested powerset, not PowerSet.
>The set of all subsets? If it isn't that then powerset is
>a very bad name. A container for efficiently maintaining
>sets of subsets would be interesting...maybe in conjunction
>with permutation library.
>Unsubscribe & other changes:

Victor A. Wagner Jr.
PGP RSA fingerprint = 4D20 EBF6 0101 B069 3817 8DBF C846 E47A
PGP D-H fingerprint = 98BC 65E3 1A19 43EC 3908 65B9 F755 E6F4 63BB 9D93
The five most dangerous words in the English language:
               "There oughta be a law"

Boost list run by bdawes at, gregod at, cpdaniel at, john at