Boost logo

Boost :

From: Alkis Evlogimenos (alkis_at_[hidden])
Date: 2003-02-05 17:16:31

On Wednesday 05 February 2003 09:11 am, Beman Dawes wrote:
> Sound suspicious. Alkis?

When I run the tests and pass with all the toolsets at once the gcc toolsets
uses gcc2.95.3 configuration.

Part of the script that creates gcc2953-tools.jam:

cat > $BOOST_BUILD_ROOT/tools/build/gcc2953-tools.jam <<EOF
    local GCC_ROOT_DIRECTORY = /opt/gcc2 ;
/opt/gcc2/lib/gcc-lib/i686-pc-linux-gnu/2.95.3/ ;
    extends-toolset gcc ;


Command to run tests:

$bjam '-sTOOLS=gcc2953 gcc2953-stlport gcc intel-linux60 intel-linux70 kylix3'
--dump-tests test &> $TEMP

If I run the tests in the same way they are run from (one at a
time) the correct gcc is picked at every invocation.

The same problem was found on Dec 23rd (I can't seem to find it on aspn to
link to it) and was fixed by Rene Rivera.

If I am not mistaken the diff applied then was the following:

Apparently the lines are still there but the problem reappeared. Maybe a
change in the build system caused this?

In any case I modified my regressing script to run one toolset at a time. The
regressions logs are uploaded but there is a problem with gcc2953-stlport
which I am looking into right now.


Boost list run by bdawes at, gregod at, cpdaniel at, john at