Boost logo

Boost :

From: Paul A. Bristow (boost_at_[hidden])
Date: 2003-07-17 16:02:20

| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]]On Behalf Of Bill Seymour
| Sent: Thursday, July 17, 2003 6:12 PM
| To: boost_at_[hidden]
| Subject: [boost] Re: Formal Review: fixed-point decimal library

| > I really don't like the name scale at all.
| Isn't that the correct term?

Perhaps - but it wasn't immediately obvious to me - I had to RTFM :-)

I might have described it as fractional (decimal) digits. The manual is correct
in saying to the right of the radix point, but isn't that more obviously and
customarily described as after the decimal point?

Would frac_digits - as in money_punct - be better than scale?

Since money_punct has used frac_digits, is this worth sticking with?

| > Nor deffrac, decscale and iosprec. Can't we do better than this,
| > even if longer?


Well Boost has always favoured clarity to curtness. Since one is probably not
going to use the manipulators a great deal, the abbreviation is hardly worth it.
How about:

showmoney $1.23 or USD 1.23 - OK
noshowmoney 1.23 - OK
showinternational USD 1.23 - more obvious than showintl
shownational $1.23 - more obvious than noshowintl

money_frac_digits - if is money, write all values with
money_punct<>::frac_digits (deffrec)
precision_frac_digits - write all value with stream precision decimal digits.
scale_frac_digits - write all value with scale fraction decimal digits.
or (decimal_frac_digits is scale is changed to frac_digits?)

Sorry if this seems to be nitpicking, but I believe the that choice of names is
really rather important.

| > The documentation is mainly pitched at a too high a level for users ...

My main criticism is the mixing of things users really need to know with more
advanced things.

| OK, I'll try to simplify it and add more examples.

Your proposals sound excellent.

| For the second and third test programs, because locale strings
| are implementation-specific, they'd be entered as command-line
| arguments.

MSVC IDE is command-line hostile - could macros could provide suitable examples
of platform-specific locale arguments?


Paul A Bristow, Prizet Farmhouse, Kendal, Cumbria, LA8 8AB UK
+44 1539 561830 Mobile +44 7714 33 02 04
Mobile mailto:pabristow_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at