Boost logo

Boost :

From: Bill Seymour (bill-at-the-office_at_[hidden])
Date: 2003-07-17 12:11:48

Paul Bristow wrote:
> Overall I vote to accept this in the Boost library.


> There are some warnings using 'strict' which are probably
> cast avoidable:
> fixed_decimal.hpp(442) : warning C4389: '==' : signed/unsigned mismatch
> fixed_decimal.hpp(446) : warning C4018: '<' : signed/unsigned mismatch
> fixed_decimal.hpp(450) : warning C4018: '>' : signed/unsigned mismatch


> I believe the best namespace is numeric.

Three votes for boost::numeric. It looks like that's the consensus.

> I really don't like the name scale at all.

Isn't that the correct term?

> Nor deffrac, decscale and iosprec. Can't we do better than this,
> even if longer?


> The documentation is mainly pitched at a too high a level
> for users ...
> [other suggestions]

OK, I'll try to simplify it and add more examples.

As regards the need for a decent test program, with which I agree
completely, my plan now is to have three of them.

- One, built around the Boost test framework, just tests whether
  the various operators and free functions are doing the arithmetic

- A second, which instantiates all the output-related templates,
  writes some interesting values like numeric_limits<decimal>::min()
  and tests the correct operations of the I/O manipulators and
  rounding modes (as arguments to operator<<), locales, and narrow
  and wide streams.

- A third which instantiates all the input-related templates and
  does the same kind of tests except that the user will have to
  enter some ad hoc values.

For the second and third test programs, because locale strings
are implementation-specific, they'd be entered as command-line

Does that seem sufficient?

--Bill Seymour

Boost list run by bdawes at, gregod at, cpdaniel at, john at