Boost logo

Boost :

From: Scott Woods (scottw_at_[hidden])
Date: 2003-10-09 20:22:20

----- Original Message -----
From: "Pavel Vozenilek" <pavel_vozenilek_at_[hidden]>
To: <boost_at_[hidden]>
Sent: Friday, October 10, 2003 1:44 PM
Subject: [boost] Re: Re: any interest in a foreach looping construct?

> "Thorsten Ottosen" <nesotto_at_[hidden]> wrote ...
> >
> > I do think it should be called FOR_EACH because it's more like a new
> > keyword. I can't imagine that will clash with anything.
> >
> My opinion too (the short name).
> Having FOR_EACH (and FOR_EACH_BACKWARDS) is useful, at least until
> gets this capability.
> Loops would be more readable and more maintainable.


Its a fairly simple thing, its implemented (not virtual) and it has some
advantages - why not just whack it in?

Cos some of the value or quality of Boost, is what *isnt* in there? Is
this so useful that it should consume Boost-space?

Like it but it doesnt seem to "group" with anything (a la "no precedent")
suspect that a group of macros re#defining the language would be rejected.


Boost list run by bdawes at, gregod at, cpdaniel at, john at