From: Gennadiy Rozental (gennadiy.rozental_at_[hidden])
Date: 2003-10-09 21:55:20
My vote is to accept this submission. I always wanted something like this. I
remember my discussion with Dave A. about 2 years ago on this very topic. We
did not see a solution at the time. And here it comes. Here couple remarks:
Shouldn't be this named apply_enable_if. It very similar to the appropriate
MPL concept and seems logical to be named the same.
2. In docs p.5
In section compiler workaround struct dummy definition in first code snippet
seems excessive and should be removed
3. utility or mpl?
It seems that submitted components belongs rather to mpl library that to
utility. What about placing it there?
Use BOOST_CHECK instead of BOOST_TEST
5. In docs p.1
In introduction section it may worth mentioning that for some tasks one may
use BOOST_STATIC_ASSERT, why it does not fit in other cases and accordingly
here is enable_if.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk