Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2003-10-10 06:06:48

"Gennadiy Rozental" <gennadiy.rozental_at_[hidden]> writes:

> My vote is to accept this submission. I always wanted something like this. I
> remember my discussion with Dave A. about 2 years ago on this very topic. We
> did not see a solution at the time. And here it comes. Here couple remarks:
> 1. lazy_enable_if
> Shouldn't be this named apply_enable_if. It very similar to the appropriate
> MPL concept and seems logical to be named the same.

I had the same thought, FWIW. I just couldn't make it sound right in
the ear, though.

On second thought, I wonder if we need it at all. Isn't

   mpl::apply_if<condition, nullary_metafunction, disabled>::type

equivalent, where disabled is a struct with no nested ::type?

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at