Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2004-02-25 07:22:00

<Bjorn.Karlsson_at_[hidden]> wrote in message
> > From: Thorsten Ottosen [mailto:nesotto_at_[hidden]]
> > > I'd say that for boost::filesystem, Dave's suggestion
> > "files" would be a
> > > great compromise.
> >
> > Why plural? We seldom name classes in plural.
> Good question, and I'm not really sure I can answer it very well (but I'll
> try):
> * It can be mentally expanded to files...ystem.

then fs is better IMO.

> * Some names work "best" in plural (like signals, type_traits, iterators,
> operators); this is of course very much IMHO.

are they the names of namespaces?

> * Just "file" seems a bit restrictive to me, but when I think about the
> namespace "files" I read "files 'n other related stuff, too".

then maybe it should be namespace io? Just like a big namespace for
algorithms, io
could hold file handling, zip streams, formatters etc.



Boost list run by bdawes at, gregod at, cpdaniel at, john at