Boost logo

Boost :

From: Matthew Vogt (mvogt_at_[hidden])
Date: 2004-03-30 17:58:00

Joaquín Mª López Muñoz <joaquin <at>> writes:

> * Proposal: "unique" and "non_unique" changed to
> "ordered_unique" and "ordered_non_unique".
> * Rationale: No one opposed and some liked
> it. Solves the clashing with std::unique. Extends nicely
> to hashed indices (unordered_unique etc.) It is more
> descriptive. In favor: Gary, Dave. Rob dislikes
> the unique/non_unique suffix, but alternatives do not
> look better IMHO.

I don't know that there is a significant chance of a clash between the two
'unique's, since it seems they will be used in different contexts.

The std::unique will be used in procedural body code, while the
boost::container::unique will be used in the (complex) declaration of
types. I think it would be a rare situtation to have 'using std;' statement
in the same context where a type was being declared with a
'using boost::container;' statement in force...
Also, disambiguation with 'std::' is both concise and familiar.

Is the symmetry between 'ordered_unique' and 'unordered_unique' worth
expanding the length of the former for?


Boost list run by bdawes at, gregod at, cpdaniel at, john at