Boost logo

Boost :

From: Pavol Droba (droba_at_[hidden])
Date: 2004-05-07 01:53:16

On Fri, May 07, 2004 at 02:40:02PM +1000, Thorsten Ottosen wrote:
> "David Abrahams" <dave_at_[hidden]> wrote in message
> | John Torjo <john.lists_at_[hidden]> writes:
> |
> | >>Let's assume this library is to be called Range Traits with
> | >> RangeConcept, ExternalRangeConcept and,
> | >> ExternalReversibleRangeConcept, can John/Mathew then find a
> | >> reasonable name for their concept:
> |
> | I'm afraid I'm going to object to any name of the form "XXX traits"
> | for this library unless it consists entirely of metafunctions.
> even in tr1 regex_traits<> contains normal functions.
> | If
> | not, can we just call it the Range library and leave it at that?
> I have no problems with that.

Would it make sense to move iterator_range to this library as well?
(given the fact it was requested to be separated from the string algo lib
during the review)
After all, it is a minimal encapsulation of the Range concept. If
the library will not be only about the traits, it might be natural to
put it there.

Just my thoughts.



Boost list run by bdawes at, gregod at, cpdaniel at, john at