Boost logo

Boost :

From: JOAQUIN LOPEZ MU?Z (joaquin_at_[hidden])
Date: 2004-06-02 14:20:15

----- Mensaje original -----
De: David Abrahams <dave_at_[hidden]>
> Joaquín Mª López Muñoz <joaquin_at_[hidden]> writes:
> > is in boost::detail::allocator), I don't have any problem with
> renaming to
> > allocator_helper (it's a better name, actually.) If no one else
> objects (which
> > I doubt) I'll apply the name change tomorrow.
> I think allocator_rebind would be a much better name than
> allocator_helper.

Ummm, the problem with allocator_rebind is that the header
contains some other stuff not strictly related to rebinding:

* partial_std_allocator_wrapper
* construct (allocator-independent construction function)
* destroy (allocator-independent destruction function)


Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo

Boost list run by bdawes at, gregod at, cpdaniel at, john at