Boost logo

Boost :

From: Jonathan Turkanis (technews_at_[hidden])
Date: 2004-08-28 14:40:21

"Daryle Walker" <darylew_at_[hidden]> wrote in message:
> On 8/27/04 6:43 PM, "Jonathan Turkanis" <technews_at_[hidden]> wrote:

> > "Rob Stewart" <stewart_at_[hidden]> wrote in message:

> >> I don't think many would have a hard time recognizing the
> >> parallel between "newl" and "endl." If you rename it to
> >> "newline," there's no chance of misunderstanding the manipulator,
> >> right?
> I know "new_line" or "newline" would be clearer, but "newl" happens to be
> the same length as typing in ['\n'] or ["\n"], four characters. If I change
> "skipl" to "skip_line", I should do the same to "newl" to be consistent.

Repeating myself a bit, I like nelwine/newlines, skip_line/skip_lines.

> I think someone (Paul?) did a performance test during last year's review. I
> don't recall how it turned out.

I'd like to see it. I remember some on comp.lang.c++ claimed to have done some
performance tests on this or a related issue, but it turned out he was using
test files consisting entirely of newlines. ;-)

> > At any rate, you and Reece have convinced me that my rejection of some of
> > manipulators was rash. I'm still not sure about ios_form; I'd like to hear
> > Daryle's rationale.
> I've read Stroustrup's C++ book (third edition) a lot. A lot of submission
> ideas come from examples in his book. The form class was one of them. I
> realized that packaging a set of formatting changes for later and/or
> repeated use could be helpful (e.g. tables).

Defintely explain this in the docs.


Boost list run by bdawes at, gregod at, cpdaniel at, john at