From: Joaquín Mª López Muñoz (joaquin_at_[hidden])
Date: 2004-09-03 04:04:53
Thorsten Ottosen ha escrito:
> Dear all,
> John Torjo asks why don't rename the Range concepts empty() function to the more idiomatic and less embarrassing
> name is_empty()?
> My initial thoughts were if this could ceate more confusion, but I'm beginning to think John is right.
> So if people would cast some yes or no votes it would be great.
I'd vote no (i.e., I'd stick with empty). It is admittedly a bad name, but it's even worse
to depart from STL terminology. I don't think it'll pose that many problems since
anybody who delves into Boost.Range will be already familiar with STL containers
and the empty() memfun.
Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo