Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2004-09-15 15:32:05


"Rob Stewart" <stewart_at_[hidden]> wrote in message
news:200409152006.i8FK6Bl06722_at_lawrencewelk.systems.susq.com...
| From: "Thorsten Ottosen" <nesotto_at_[hidden]>
| > "Jeff Flinn" <TriumphSprint2000_at_[hidden]> wrote in message
| >
| > | begin( as_const( as_reverse(x) ) )
| > | begin( as_reverse( as_const(x) ) )
| >
| > yes, I think so with some metaprgramming, but its getting quite hard to
read
| > compared to the single version.
|
| Those are getting harder to read, but they do offer complete
| generality. Composing those is straightforward, whereas you
| could forget the correct order if there was only
| as_const_reverse(), for example.

yeah, but they are conceptually somewhat different: as_const() adds constness
which
works all over the plaec whereas as_reverse() only works for certain
iterators; we already have
rbegin(a) and so it seems that only as_const() would be needed.

If so, its not a part of boost.range but boost.util

br

Thorsten


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk