Boost logo

Boost :

From: John Torjo (john.lists_at_[hidden])
Date: 2004-09-21 10:29:23

>>>2. If primary target is collection formatting wouldn't it be better to
>>>name library "collection formats something"?
>>This is a good idea. The name is from when the library just had output
>>support, thus the "outfmt" directory in the sandbox. I am thinking about
>>moving to a "formatter" directory. What do other people think?
> I'm -1. Having "format" and "formatter" is confusing. The name should
> somehow mention that you format data structures.

I second that - 'formatter' is just confusing.
However, something like 'coll_format' or 'sequence_format' - I'm ok with


John Torjo
-- john_at_[hidden]
Contributing editor, C/C++ Users Journal
-- "Win32 GUI Generics" -- generics & GUI do mix, after all
-- v1.4 - save_dlg - true binding of your data to UI controls!
    + easily add validation rules (win32gui/examples/smart_dlg)

Boost list run by bdawes at, gregod at, cpdaniel at, john at