Boost logo

Boost :

From: Roland Weiss (weissr_at_[hidden])
Date: 2004-11-08 09:01:14

John Torjo wrote:

>>> No comments of the code itself, however I'm not a fan of rng as a
>>> namespace, I keep reading Random Number Generator.
>>> helpfully though I can't think of an alternative!
>>> range (likely to conflict?)
>>> irange (likely to be used as a variable name in place of 'i' ?)
>>> irl (not good either)
>>> rangelib (too long?)
>> Tradition would dictate "ranges"
> I'm fine with ranges:: namespace, although I find it a little big
> (containing too many chars).

I prefer descriptive names, and everyone is free to declare a namespace
alias in his own code...

namespace br = boost::ranges;


> Best,
> John

Boost list run by bdawes at, gregod at, cpdaniel at, john at