Boost logo

Boost :

From: Joaquín Mª López Muñoz (joaquin_at_[hidden])
Date: 2005-02-04 10:50:53

Peter Dimov ha escrito:

> Joaquín Mª López Muñoz wrote:
> > John Maddock ha escrito:
> >
> >>> With the recent addition of TR1 aligned_storage to
> >>> Boost.TT, there's a nasty collision with a class named
> >>> exactly the same and living in boost/aligned_storage.hpp
> >>> (this class is a spin-off from Boost.Variant, IIRC.)
> >>> I think this has been discussed some months ago, but
> >>> with no resolution to the best of my knowledge.
> >>>
> >>> Apart from the symbol clash, these two classes do not
> >>> provide the same functionality, so I guess it'd be sensible
> >>> to rename the older aligned_storage to something else.
> >>> Ideas?
> >>
> >> Darn, normally I'd say that the older version has priority over the
> >> name, however in this case since aligned_storage is part of the TR,
> >> I'm leaning toward agreeing that we should rename the old version.
> >
> > I think this is the only reasonable option.
> In my opinion, the older version needs to be removed entirely and the
> libraries should be updated to use the TR1 version of aligned_storage.

The problem is that the older aligned_storage provides a different
functionality than the std::tr1 (it gives you uninitialized aligned stack space.)
It is a mere accident that both classes are named the same IMHO.

Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo

Boost list run by bdawes at, gregod at, cpdaniel at, john at