From: Joaquín Mª López Muñoz (joaquin_at_[hidden])
Date: 2005-02-16 08:34:54
Thorsten Ottosen ha escrito:
> Dear all,
> I will soon start to write some more documentation for the
> indirect container library (formerly called the smart container library).
> Before I start on that I would like to get a vote on the preferred naming
> 1. the library itself
> 2. library classes
> Ad 1: library name:
> Boost.Indirect Cotainer was suggested by Joaquin. It sounds reasonable to me.
> I don't have any alternatives, but suggestions are welcome.
Maybe Boost Pointer Containers would also do, specially if you keep
the ptr_xxx names.
> Ad 2: library classes:
> The library currently consists of the following major classes in namespace
> Should these names persist? Or should we go for something like
> indirect_array, indirect_vector etc?
If you plan to extend the lib as outlined in the "future work" section
to cope with pointer-like objects like shared_ptr (an maybe iterators?)
then indirect_xxx would fit better, though ptr_xxx is evocative enough.
Just my 2 cents, anyway.
Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk