Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2005-03-24 05:57:33

"Eric Niebler" <eric_at_[hidden]> wrote in message
| David Abrahams wrote:
| > "Eric Niebler" <eric_at_[hidden]> writes:
| >
| >>But you still haven't given me a reason I can understand why it
| >>shouldn't be "boost_range_begin()" etc..
| >
| > Peter Dimov made some excellent arguments in the thread containing
| > (click the
| > subject line to see the thread).
| >
| It's true he made some excellent arguments in that thread, but this is a
| different argument. ;-) Once you accept as a given that we should be
| using an ADL customization point, what should we call it?
| In this message:
| You say: "You're much safer using boost_range_end or range_end if you're
| trying to keep it small. I don't see any reason to keep it small,
| though: users won't be invoking that function directly."
| And I agree, it should be boost_range_end. We are in agreement. Now we
| just need to convince Thorsten. :-)

since we can't use the short version (ity clashes with range_size<TA)
then let's go with the boost prefix.

I'll commit shortly


Boost list run by bdawes at, gregod at, cpdaniel at, john at